FIJI - Microscope Measurement Tools

From UCSB Nanofab Wiki
Jump to: navigation, search

This plugin for FIJI allows UCSB NanoFab users to make calibrated measurements on microscope and SEM images with freely available software, after the image acquisition.

Calibrations for NanoFab microscopes are pre-loaded in this UCSB-specific fork of the plugin.

(You will need to record the microscope name & objective used when you initially save your photos in the lab.)

Screenshot of Drop-Down list of calibrations for UCSB microscopes.
Drop-Down list of calibrations for UCSB microscopes.
Example of measurements draw on a microscope image
Example of measurements drawn on a microscope image

Software

  • FIJI is an open source package, based on ImageJ, for scientific image analysis across many disciplines.
    • Download here.
  • Microscope Measurement Tools (UCSB Fork) is a plug-in with pre-configured settings that provides the scaling factors for the UCSB NanoFab microscopes and SEMs. It also contains a script for drawing line measurements onto an image.
    • This just automates the use of the `Set Scale...` built-in function.

Installation

  1. Download the Microscope Measurement Tools package. (Will be referred to as "MMT" for the rest of the tutorial.)
  2. Download FIJI
  3. Install FIJI accordingly.
  4. Unzip the downloaded MMT zipfile.
    1. Locate the Analyze folder inside the package.
  5. Navigate to the FIJI Scripts folder, in FIJI.app / plugins / Scripts
  • On Windows, the folder looks like this:
Screenshot: Windows - Where to place the Analyze folder.
Windows - Where to place the Analyze folder.
  • On Mac, first Right-click FIJI.app and choose "Show Package Contents", and the folder will look like this:
MicroscopeMeasurementTools - FIJI Install - Mac Show Package Contents.png
Screenshot: MacOS - Where to place the Analyze folder.
MacOS - Where to place the Analyze folder.
  1. Copy the Analyze folder from MMT into the FIJI Scripts folder.
    1. In the off chance that an Analyze folder already exists in the FIJI scripts folder, merge the two rather than overwriting. You must have placed another script in the same menu location.
  2. (Re)Launch FIJI.
    1. There should now be a new menu option in Analyze > Microscope Measurement Tools

Add shortcut keys

Optionally add a shortcut key to execute the scripts.

To Do: add steps

Make a Measurement on an Image

  • Download an image from one of our microscopes on Nanofiles.
    • You must know which microscope and which objective the image was saved with.
  • Open the image in FIJI (or open a copy to avoid overwriting the file)
  • Run the script Analyze > Microscope Measurement Tools > Choose Microscope Calibration...
  • Select the appropriate microscope and objective from the list and click OK
    • The calibration has now been applied to the image. Any FIJI functions will now use the correct scaling.
  • Enable the Line tool. Draw anywhere on the image you want to measure.
    • While dragging, the (FIJI is just ImageJ) control window will show the calibrated measurement value of your line.
  • To draw the measurement on the image, select the menu Analyze > Microscope Measurement Tools > Draw Measurement - Line
    • This can not be undone without reloading the image, so be sure to use Save As….
    • You can make a new Overlay before applying the Drawing to make the line moveable or erasable.

SEM Images

Images saved from the JEOL SEM automatically save a Text file with the same name, which contains the scaling information.

As long as this text file is kept in the same location as the image file, the function Choose Microscope Calibration >> JEOL SEM - AutoCal from TXT will set the measurement scale appropriately.

References