Difference between revisions of "MLA150 - Large Image GDS Generation"

From UCSB Nanofab Wiki
Jump to navigation Jump to search
(pasted method)
(updated formatting/numbered list)
 
(One intermediate revision by the same user not shown)
Line 1: Line 1:
Instructions on how to take a regular rasterized image (eg. JPG, BMP, PNG etc.) and convert it into a vectorized format compatible with the MLA150.  This produces a much smaller file than a raw BMP image, because large-area polygons are created, as opposed to the BMP file defining each ~4µm pixel across a 150mm wafer (which hits the RAM limit on the computer).
+
How to convert a regular rasterized image (eg. JPG, BMP, PNG etc.) and into a vectorized format (GDS,DXF) compatible with the MLA150.  This produces a much smaller file than a raw BMP image, because large-area polygons are created, as opposed to the BMP file defining each ~4µm pixel across a 150mm wafer (which hits the RAM limit on the computer).
  
 
In this example, we convert the image into a 1-bit black-and-white image using the free software [https://www.gimp.org GIMP], and then convert to a Vector format using the free software [https://inkscape.org InkScape].  Then we correct the scale and convert to GDS using the free software [https://www.klayout.de KLayout]., which is then ready for exposure on the MLA.
 
In this example, we convert the image into a 1-bit black-and-white image using the free software [https://www.gimp.org GIMP], and then convert to a Vector format using the free software [https://inkscape.org InkScape].  Then we correct the scale and convert to GDS using the free software [https://www.klayout.de KLayout]., which is then ready for exposure on the MLA.
  
==== Procedure ====
+
====Procedure====
'''[https://www.gimp.org/ GIMP]:''' (can also do in another image editor, such as Paint.exe)
 
  
open the Image (JPG, PNG, BMP etc.),  
+
# In '''[https://www.gimp.org/ GIMP]:''' (can also do in another image editor, such as Paint.exe)
 
+
## open the Image (JPG, PNG, BMP etc.),  
Image > Mode > Indexed > 1-bit
+
## Image > Mode > Indexed > 1-bit
 
+
### Optional: Dither to handle grey values (haven't tried this).
Optional: Dither to handle grey values, haven't tried this.
+
## Can edit by painting etc.
 
+
## Save as any JPG, PNG, BMP format
Can edit by painting etc.
+
# In '''[https://inkscape.org/ Inkscape]:''' vectorize into DXF
 
+
## Open the Image file, default options
Save as any JPG, PNG, BMP format
+
## Click on the Image with the Arrow tool, to select it.
 
+
## Path > Trace Bitmap (options affect curves/resolution)
'''[https://inkscape.org/ Inkscape]:'''
+
## Use the “Update” button to show a Preview of the Path that will be created.
 
+
## Set the Options: Trace BitMap > Single-Scan > AutoTrace (dropdown menu).  
Open the Image file, default options
+
## [OK] to create the Path, then Close the “Trace Bitmap” window.
 
+
## Creates a new Path object that outlines the image
Click on the Image with the Arrow tool, to select it.
+
## Use the Arrow select tool to select the Image
 
+
### Bottom status bar shows what object is selected
Path > Trace Bitmap (options affect curves/resolution)
+
### Option/Alt-Click to select obscured objects
 
+
### Make sure PATH is <u>Not</u> selected
- Use the “Update” button to show a Preview of the Path that will be created.
+
## Delete the Image object.  File should now have only the Path object in it.
 
+
## File > Save a Copy… > DXF (Autocad R14)  
- Options: Trace BitMap > Single-Scan > AutoTrace (dropdown menu).  
+
## UNCHECK "Robo" and "LWPOLYLINE" - important, or the lines won’t be connected as a single object.
 
+
## You now have a DXF vector file of the image.
- [OK] to create the Path, then Close the “Trace Bitmap” window.
+
# In '''[https://www.klayout.de/ Klayout]:''' convert to GDS
 
+
## Open the DXF in Klayout
- Creates a new Path object that outlines the image
+
## Use Cell Instance to scale up to desired size:
 
+
### Create a new Cell
Use the Arrow select tool to select the Image
+
###Instance the original Cell into that.
 
+
###Edit Cell Instance properties to adjust scaling
- bottom bar shows what object is selected
+
##Use Move tool to Center image at 0,0
 
+
##Save as GDS
- Option/Alt-Click to select obscured objects
+
##Change file extension to ''lower case'' “gds” important, or MLA ''convert'' software won’t see the file.
 
+
##Take note of which Cell & Layer should be printed
- Make sure PATH is Not selected
+
# On the '''[[Maskless Aligner (Heidelberg MLA150)|MLA]]:''' load for exposure
 
+
## [Convert Design] and Import the GDS,  
Delete the Image.  File should have only the Path object in it.
+
## Choose correct Cell from dropdown for "GDS Structure"
 
+
## Set correct Layer: set 1st line to correct layer & uncheck the others
File > Save a Copy… > DXF (Autocad R14)  
+
## [Viewer] to make sure scale is correct
 
+
## Ready to expose the pattern as normal.
> UNCHECK "Robo" and "LWPOLYLINE" - important, or the lines won’t be connected as a single object.
 
 
 
'''[https://www.klayout.de/ Klayout]:'''
 
 
 
Open the DXF in Klayout
 
 
 
Use Cell Instance to scale up to desired size:
 
* Create a new Cell
 
* Instance the original Cell into that.
 
* Edit Cell Instance properties to adjust scaling
 
Use Move tool to Center image at 0,0
 
 
 
Save as GDS
 
* Change file extension to ''lower case'' “gds” important, or MLA ''convert'' software won’t see the file.
 
Take note of which Cell & Layer should be printed
 
 
 
'''MLA:'''
 
 
 
[Convert Design] and Import the GDS,  
 
 
 
Choose correct Cell from dropdown
 
 
 
Set correct Layer: set 1st line to correct layer & uncheck the others
 
 
 
[Viewer] to make sure scale is correct
 
 
 
Ready to expose the pattern as normal.
 

Latest revision as of 16:45, 29 July 2022

How to convert a regular rasterized image (eg. JPG, BMP, PNG etc.) and into a vectorized format (GDS,DXF) compatible with the MLA150. This produces a much smaller file than a raw BMP image, because large-area polygons are created, as opposed to the BMP file defining each ~4µm pixel across a 150mm wafer (which hits the RAM limit on the computer).

In this example, we convert the image into a 1-bit black-and-white image using the free software GIMP, and then convert to a Vector format using the free software InkScape. Then we correct the scale and convert to GDS using the free software KLayout., which is then ready for exposure on the MLA.

Procedure

  1. In GIMP: (can also do in another image editor, such as Paint.exe)
    1. open the Image (JPG, PNG, BMP etc.),
    2. Image > Mode > Indexed > 1-bit
      1. Optional: Dither to handle grey values (haven't tried this).
    3. Can edit by painting etc.
    4. Save as any JPG, PNG, BMP format
  2. In Inkscape: vectorize into DXF
    1. Open the Image file, default options
    2. Click on the Image with the Arrow tool, to select it.
    3. Path > Trace Bitmap (options affect curves/resolution)
    4. Use the “Update” button to show a Preview of the Path that will be created.
    5. Set the Options: Trace BitMap > Single-Scan > AutoTrace (dropdown menu).  
    6. [OK] to create the Path, then Close the “Trace Bitmap” window.
    7. Creates a new Path object that outlines the image
    8. Use the Arrow select tool to select the Image
      1. Bottom status bar shows what object is selected
      2. Option/Alt-Click to select obscured objects
      3. Make sure PATH is Not selected
    9. Delete the Image object.  File should now have only the Path object in it.
    10. File > Save a Copy… > DXF (Autocad R14)
    11. UNCHECK "Robo" and "LWPOLYLINE" - important, or the lines won’t be connected as a single object.
    12. You now have a DXF vector file of the image.
  3. In Klayout: convert to GDS
    1. Open the DXF in Klayout
    2. Use Cell Instance to scale up to desired size:
      1. Create a new Cell
      2. Instance the original Cell into that.
      3. Edit Cell Instance properties to adjust scaling
    3. Use Move tool to Center image at 0,0
    4. Save as GDS
    5. Change file extension to lower case “gds” important, or MLA convert software won’t see the file.
    6. Take note of which Cell & Layer should be printed
  4. On the MLA: load for exposure
    1. [Convert Design] and Import the GDS,
    2. Choose correct Cell from dropdown for "GDS Structure"
    3. Set correct Layer: set 1st line to correct layer & uncheck the others
    4. [Viewer] to make sure scale is correct
    5. Ready to expose the pattern as normal.