Difference between revisions of "FIJI - Microscope Measurement Tools"

From UCSB Nanofab Wiki
Jump to: navigation, search
(Initial instruction, no links)
 
m (switch image example)
 
(6 intermediate revisions by the same user not shown)
Line 1: Line 1:
 
This plugin for FIJI allows UCSB NanoFab users to make calibrated measurements on microscope and SEM images with freely available software, after the image acquisition.
 
This plugin for FIJI allows UCSB NanoFab users to make calibrated measurements on microscope and SEM images with freely available software, after the image acquisition.
  +
  +
Calibrations for NanoFab microscopes are pre-loaded in this UCSB-specific fork of the plugin.
  +
  +
(You will need to record the microscope name & objective used when you initially save your photos in the lab.)
  +
[[File:FIJI MMT UCSB-Fork Choose Microscope Calibration drop down.png|alt=Screenshot of Drop-Down list of calibrations for UCSB microscopes.|none|thumb|450x450px|Drop-Down list of calibrations for UCSB microscopes.]]
  +
[[File:MicroscopeMeasurementTools - FIJI draw measurement - line.png|alt=Example of measurements draw on a microscope image|none|thumb|450x450px|Example of measurements drawn on a microscope image]]
   
 
== Software ==
 
== Software ==
Line 9: Line 15:
   
 
== Installation ==
 
== Installation ==
# Download FIJI and the Microscope Measurement Tools packages.
+
# Download the [https://github.com/demisjohn/Microscope-Measurement-Tools-UCSB/archive/master.zip Microscope Measurement Tools package]. (Will be referred to as "''MMT''" for the rest of the tutorial.)
  +
# [http://fiji.sc Download FIJI]
 
# Install FIJI accordingly.
 
# Install FIJI accordingly.
  +
# Unzip the downloaded MMT zipfile.
# Unzip the Microscope Measurement Tools (aka. MMT) file. Locate the `Analyze` folder inside the package.
 
# Navigate to the FIJI `Scripts` folder, in
+
## Locate the '''''Analyze''''' folder inside the package.
  +
# Navigate to the FIJI '''''Scripts''''' folder, in '''''FIJI.app / plugins / Scripts'''''
## FIJI.app/etc. {{todo|get path}}
 
  +
::* On Windows, the folder looks like this:
# Copy the `Analyze` folder from MMT into the FIJI `Scripts` folder.
 
  +
::: [[File:MicroscopeMeasurementTools - FIJI Install Directory - WinXP.jpg|alt=Screenshot: Windows - Where to place the Analyze folder.|none|thumb|474x474px|Windows - Where to place the Analyze folder.]]
## In the off chance that an `Analyze` folder already exists in the FIJI scripts folder, merge the two rather than overwriting. You must have placed another script in the same menu location.
 
  +
  +
::* On Mac, first Right-click FIJI.app and choose "'''''Show Package Contents'''''", and the folder will look like this:
  +
::: [[File:MicroscopeMeasurementTools_-_FIJI_Install_-_Mac_Show_Package_Contents.png|border|209x209px]]
  +
:::
  +
:::
  +
::: [[File:FIJI Install Directory - MacOS.png|alt=Screenshot: MacOS - Where to place the Analyze folder.|none|thumb|630x630px|MacOS - Where to place the Analyze folder.]]
  +
# Copy the '''''Analyze''''' folder from MMT into the FIJI '''''Scripts''''' folder.
  +
## In the off chance that an '''''Analyze''''' folder already exists in the FIJI scripts folder, merge the two rather than overwriting. You must have placed another script in the same menu location.
 
# (Re)Launch FIJI.
 
# (Re)Launch FIJI.
## There should now be a new menu option in `Analyze > Microscope Measurement Tools`
+
## There should now be a new menu option in '''''Analyze > Microscope Measurement Tools'''''
   
 
=== Add shortcut keys ===
 
=== Add shortcut keys ===
Line 27: Line 42:
 
* Download an image from one of our microscopes on Nanofiles.
 
* Download an image from one of our microscopes on Nanofiles.
 
** You must know which microscope and '''which objective the image was saved with'''.
 
** You must know which microscope and '''which objective the image was saved with'''.
* Open the image in FIJI
+
* Open the image in FIJI (or open a copy to avoid overwriting the file)
* Run the script `Analyze > Microscope Measurement Tools > Choose Microscope Calibration...`
+
* Run the script '''''Analyze > Microscope Measurement Tools > Choose Microscope Calibration...'''''
* Select the appropriate microscope and objective from the list and click {{todo|Apply}}
+
* Select the appropriate microscope and objective from the list and click '''''OK'''''
 
** The calibration has now been applied to the image. Any FIJI functions will now use the correct scaling.
 
** The calibration has now been applied to the image. Any FIJI functions will now use the correct scaling.
 
* Enable the Line tool. Draw anywhere on the image you want to measure.
 
* Enable the Line tool. Draw anywhere on the image you want to measure.
** While dragging, the FIJI control window will show the calibrated measurement value of your line.
+
** While dragging, the '''''(FIJI is just ImageJ)''''' control window will show the calibrated measurement value of your line.
* To draw the measurement on the image, select the menu `Analyze > Microscope Measurement Tools > Draw Measurement - Line`
+
* To draw the measurement on the image, select the menu '''''Analyze > Microscope Measurement Tools > Draw Measurement - Line'''''
** This can not be undone without reloading the image, so be sure not to Save the file.
+
** This can not be undone without reloading the image, so be sure to use '''''Save As…'''''.
 
** You can make a new Overlay before applying the Drawing to make the line moveable or erasable.
 
** You can make a new Overlay before applying the Drawing to make the line moveable or erasable.
  +
**
   
 
== SEM Images ==
 
== SEM Images ==
Images saved from the JEOL SEM automatically save a Text file with the same name, which contains the scaling information.
+
Images saved from the [[Field Emission SEM 2 (JEOL 7600F)|JEOL SEM]] automatically save a Text file with the same name, which contains the scaling information.
   
As long as this text file is kept in the same location as the image file, the function `Choose Microscope Calibration >> JEOL SEM - AutoCal from TXT` will set the measurement scale appropriately.
+
As long as this text file is kept in the same location as the image file, the function '''''Choose Microscope Calibration >> JEOL SEM - AutoCal from TXT''''' will set the measurement scale appropriately.
   
 
== References ==
 
== References ==
* The original general-use plugin can be found here: Microscope Measurement Tools on GitHub.
+
* The original general-use plugin can be found here: [https://github.com/demisjohn/Microscope-Measurement-Tools Microscope Measurement Tools on GitHub.]
* Other FIJI plug-ins available.
+
* Many other FIJI plug-ins [https://imagej.net/Category:Plugins are available here].
* Setting the scale on any image with FIJI or ImageJ.
+
* [https://imagej.net/Spatial_Calibration Setting the scale on any image with FIJI or ImageJ].

Latest revision as of 11:02, 10 June 2019

This plugin for FIJI allows UCSB NanoFab users to make calibrated measurements on microscope and SEM images with freely available software, after the image acquisition.

Calibrations for NanoFab microscopes are pre-loaded in this UCSB-specific fork of the plugin.

(You will need to record the microscope name & objective used when you initially save your photos in the lab.)

Screenshot of Drop-Down list of calibrations for UCSB microscopes.
Drop-Down list of calibrations for UCSB microscopes.
Example of measurements draw on a microscope image
Example of measurements drawn on a microscope image

Software

  • FIJI is an open source package, based on ImageJ, for scientific image analysis across many disciplines.
    • Download here.
  • Microscope Measurement Tools (UCSB Fork) is a plug-in with pre-configured settings that provides the scaling factors for the UCSB NanoFab microscopes and SEMs. It also contains a script for drawing line measurements onto an image.
    • This just automates the use of the `Set Scale...` built-in function.

Installation

  1. Download the Microscope Measurement Tools package. (Will be referred to as "MMT" for the rest of the tutorial.)
  2. Download FIJI
  3. Install FIJI accordingly.
  4. Unzip the downloaded MMT zipfile.
    1. Locate the Analyze folder inside the package.
  5. Navigate to the FIJI Scripts folder, in FIJI.app / plugins / Scripts
  • On Windows, the folder looks like this:
Screenshot: Windows - Where to place the Analyze folder.
Windows - Where to place the Analyze folder.
  • On Mac, first Right-click FIJI.app and choose "Show Package Contents", and the folder will look like this:
MicroscopeMeasurementTools - FIJI Install - Mac Show Package Contents.png
Screenshot: MacOS - Where to place the Analyze folder.
MacOS - Where to place the Analyze folder.
  1. Copy the Analyze folder from MMT into the FIJI Scripts folder.
    1. In the off chance that an Analyze folder already exists in the FIJI scripts folder, merge the two rather than overwriting. You must have placed another script in the same menu location.
  2. (Re)Launch FIJI.
    1. There should now be a new menu option in Analyze > Microscope Measurement Tools

Add shortcut keys

Optionally add a shortcut key to execute the scripts.

To Do: add steps

Make a Measurement on an Image

  • Download an image from one of our microscopes on Nanofiles.
    • You must know which microscope and which objective the image was saved with.
  • Open the image in FIJI (or open a copy to avoid overwriting the file)
  • Run the script Analyze > Microscope Measurement Tools > Choose Microscope Calibration...
  • Select the appropriate microscope and objective from the list and click OK
    • The calibration has now been applied to the image. Any FIJI functions will now use the correct scaling.
  • Enable the Line tool. Draw anywhere on the image you want to measure.
    • While dragging, the (FIJI is just ImageJ) control window will show the calibrated measurement value of your line.
  • To draw the measurement on the image, select the menu Analyze > Microscope Measurement Tools > Draw Measurement - Line
    • This can not be undone without reloading the image, so be sure to use Save As….
    • You can make a new Overlay before applying the Drawing to make the line moveable or erasable.

SEM Images

Images saved from the JEOL SEM automatically save a Text file with the same name, which contains the scaling information.

As long as this text file is kept in the same location as the image file, the function Choose Microscope Calibration >> JEOL SEM - AutoCal from TXT will set the measurement scale appropriately.

References