Difference between revisions of "Calculators + Utilities"

From UCSB Nanofab Wiki
Jump to navigation Jump to search
(→‎KLayout: handling large files)
Line 67: Line 67:
 
*Fast and very effective viewing of layer overlay, overlay multiple files, cell hierarchy etc.
 
*Fast and very effective viewing of layer overlay, overlay multiple files, cell hierarchy etc.
 
*Supports the same core functionality as L-Edit - hierarchical Cell Instances, arrays, programmable Cells (PCells) etc.
 
*Supports the same core functionality as L-Edit - hierarchical Cell Instances, arrays, programmable Cells (PCells) etc.
*‘Before’ starting your design, set the '''''Layout Properties > Database Unit''''' to something small eg. 0.0001 µm (0.1nm).
+
*‘Before’ starting your design, set the '''''Layout Properties > Database Unit''''' to something small eg. the default of 0.001 µm (1nm) is usually fine.
*Turn on the display of the Origin (0,0) in '''''Preferences > Display > Background > Axis''''' = choose an option apart from the default "invisible", eg. "'''''Lines with Ticks'''''".
+
*Turn on the display of the Origin (0,0) in '''''Preferences > Display > Background > Axis''''' = change from the default "invisible", eg. "'''''Lines with Ticks'''''".
 
*How to draw circles:  You have to draw a square, and then apply the function '''''Edit>Selection>Convert to PCell''>Basic.CIRCLE'''.  Another way is to permanently convert to a polygon with '''''Edit>Selection>Round Corners''''' function with '''''Outer Corner Radius''''' = the desired circle radius (radius is not changeable in this method, but computation may be faster for a large number of objects). This is for compatibility, because GDS files do not have a "circle" primitive built-in, so instead it creates a polygon. Make sure you include enough polygon points, eg. 100. See the [https://www.klayout.de/forum/discussion/142/making-circles forum help pages] on this for more info.
 
*How to draw circles:  You have to draw a square, and then apply the function '''''Edit>Selection>Convert to PCell''>Basic.CIRCLE'''.  Another way is to permanently convert to a polygon with '''''Edit>Selection>Round Corners''''' function with '''''Outer Corner Radius''''' = the desired circle radius (radius is not changeable in this method, but computation may be faster for a large number of objects). This is for compatibility, because GDS files do not have a "circle" primitive built-in, so instead it creates a polygon. Make sure you include enough polygon points, eg. 100. See the [https://www.klayout.de/forum/discussion/142/making-circles forum help pages] on this for more info.
  
Line 77: Line 77:
 
*Viewing only some levels of the heirachy, to prevent drawing all objects: [https://www.klayout.de/doc/manual/hier.html KLayout Docs: Viewing Cell Heirarchy]
 
*Viewing only some levels of the heirachy, to prevent drawing all objects: [https://www.klayout.de/doc/manual/hier.html KLayout Docs: Viewing Cell Heirarchy]
 
OASIS files tend to be much smaller than GDS files, and they also save the Layer Names (not just number). Alternatively, in KLayout the function '''File > Save Session''' will save the entire view including layer styles and window/zoom locations will be saved. You can share this file, as the entire design file is embedded within it, but it may not be as robust between KLayout versions.
 
OASIS files tend to be much smaller than GDS files, and they also save the Layer Names (not just number). Alternatively, in KLayout the function '''File > Save Session''' will save the entire view including layer styles and window/zoom locations will be saved. You can share this file, as the entire design file is embedded within it, but it may not be as robust between KLayout versions.
 +
 +
<u>Handling very large files</u>: If you will be generating millions of identical shapes (eg. repeating array of circles), the file size can quickly become enormous due to all the stored polygon points. You can reduce the number of polygon points stored by:
 +
# Reduce the number of points in each shape/circle if possible. 
 +
# Use Cell instancing so that only one, or a few, polygons are defined, and that same polygon is then only referenced as a repeating Cell instance. (See above for tutorials). 
 +
# The OAS file type generates much smaller files, and most photomask vendors can accept this.  Photomask vendors are used to handling large files. 
 +
# Photomask vendors are able to take multiple files and insert them into the final reticle – you just need to provide a clear schematic (eg. slides) showing the exact insertion coordinates for each file (with respect to the origin of each file).  They can also do some boolean operations (for a fee).
  
 
==== Example CAD File ====
 
==== Example CAD File ====

Revision as of 07:10, 20 January 2021

This page lists a few online calculators and utilities that are useful to lab users.

Fabrication Processes & Converters

Material Parameters

Wet Etching

Refractive Indices

Optical constants of many common materials. Useful for Optical thin-film analysis (ellipsometry/spectroscopic fitting), laser etch monitoring, optical filter/mirror/anti-reflection coating design, photonic devices etc.

Scripts + Programs

Analysis Programs

  • AmScope Software - microscope image analysis software
    • AmScope Calibration File containing calibrations for all NanoFab microscopes: Download Here
    • Also available on Nanofiles-SFTP / Manuals / Amscope
  • FIJI - scientific image anaylsis software
  • Gwyddion - free analysis software for Atomic Force Microscopes (AFMs) and other 3D data.
    • Sophisticated leveling, slicing, roughness/particulate analysis functions etc.
    • Can open Bruker NanoScope files, from the AFM
  • ProfilmOnline.com (Filmetrics) - online analysis/storage/sharing of 3D topographical data and images.
    • You can share an interactive 3D render of your AFM or Profilm3D scans with this tool.
    • Example AFM Scan, taken with NanoFab equipment, shared online for interactive analysis (slice, flatten etc.).

CAD Layout Programs

Use these for designing your lithography mask plates.

L-Edit

Powerful multi-layer layout program. Sophisticated object instantiation and array layout, to reduce files sizes and easily push changes to multiple cells.

KLayout

A free, open-source, and fast/simple CAD tool for mask/reticle layout. Download at klayout.de.

  • Available on Windows, Mac or *Nix.
  • Easily scriptable with Python or Ruby, with decent tutorials.
  • Fast and very effective viewing of layer overlay, overlay multiple files, cell hierarchy etc.
  • Supports the same core functionality as L-Edit - hierarchical Cell Instances, arrays, programmable Cells (PCells) etc.
  • ‘Before’ starting your design, set the Layout Properties > Database Unit to something small eg. the default of 0.001 µm (1nm) is usually fine.
  • Turn on the display of the Origin (0,0) in Preferences > Display > Background > Axis = change from the default "invisible", eg. "Lines with Ticks".
  • How to draw circles: You have to draw a square, and then apply the function Edit>Selection>Convert to PCell>Basic.CIRCLE. Another way is to permanently convert to a polygon with Edit>Selection>Round Corners function with Outer Corner Radius = the desired circle radius (radius is not changeable in this method, but computation may be faster for a large number of objects). This is for compatibility, because GDS files do not have a "circle" primitive built-in, so instead it creates a polygon. Make sure you include enough polygon points, eg. 100. See the forum help pages on this for more info.

CAD Design Tips

It is highly recommended that you understand and use the concept of "Cells" in your design. This circumvents many problems with enormous file sizes (due to huge numbers of identical polygons), and if used properly, helps tremendously with programming the Stepper lithography machines. Links to documentation below:

OASIS files tend to be much smaller than GDS files, and they also save the Layer Names (not just number). Alternatively, in KLayout the function File > Save Session will save the entire view including layer styles and window/zoom locations will be saved. You can share this file, as the entire design file is embedded within it, but it may not be as robust between KLayout versions.

Handling very large files: If you will be generating millions of identical shapes (eg. repeating array of circles), the file size can quickly become enormous due to all the stored polygon points. You can reduce the number of polygon points stored by:

  1. Reduce the number of points in each shape/circle if possible.
  2. Use Cell instancing so that only one, or a few, polygons are defined, and that same polygon is then only referenced as a repeating Cell instance. (See above for tutorials).
  3. The OAS file type generates much smaller files, and most photomask vendors can accept this. Photomask vendors are used to handling large files.
  4. Photomask vendors are able to take multiple files and insert them into the final reticle – you just need to provide a clear schematic (eg. slides) showing the exact insertion coordinates for each file (with respect to the origin of each file). They can also do some boolean operations (for a fee).

Example CAD File

Here is an example CAD file, showing the use of Layers and Cells, designed in KLayout. The device is fictional, for illustrative purposes only.

  • CAD_Tutorial_for_ASML_Reticle_v1.OAS (Demis D. John)
  • Cell "Device_Layout" shows a single device, with each Layer overlaid as it would be in a fabricated device. Each Layer (eg. a "process step" such as Mesa etch, Pad Metal etc.) is placed into it's own Cell.
screenshot of KLayout view of Device_Layout
"Device_Layout" Cell showing as the "top cell"
  • Every Cell's Origin (0,0) lies on top of one another in the final Device_Layout.
    • One way this can be accomplished is by selecting the objects/polygons you want to make into a new Cell, then use the function Edit > Selection > Make Cell, and uncheck the "Put Origin at..." checkbox, so the new Cell maintains the same origin as the original view.
  • The Cell "Reticle_Layout" can be exported by itself (right-click the Cell name), for sending to the photomask manufacturer.
  • See the ASML Mask Making Guidelines page for an example of how to program this Reticle into an ASML Stepper job.

General Calculators

  • Anaconda Python
    • A free Matlab-like IDE and GUI, using the Python language. The Spyder interface is modeled after Matlab.
    • Includes the scientific Python libraries needed for array math (numpy), plotting (matplotlib), data science (pandas) and many others. Many open-source packages are available to extend capabilities. The PyVisa module adds equipment control capabilities for automated measurements.
  • Wolfram Alpha
    • A versatile online interpreter/calculator, allowing calculations such as "Volume of 1.5g of Silicon", "melting point of SiO2" or "520°C in Fahrenheit".

Python Scripts

These scripts are best run in the Spyder IDE, which is easily installed via Anaconda, Python(X,Y), or by directly compiling Spyder using a command-line package manager.

  • Keithley I-V Sweep
    • Sweep voltage and plot current vs. voltage using a Keithley SMU.
    • Already installed at the Probe Station in Bay 4, and on the QFI Thermal Microscope (Use Python(X,Y) to run).
    • Requires the pyvisa python module.
  • QFIScope Thermal Analysis
    • Import 2D temperature data from the IR Thermal Microscope (QFI) and plot temperature profiles at user-specified locations.
    • Already installed on the QFI Infrared Microscope.
  • Laser Etch Monitor Simulation in Python
    • Simulate your laser endpoint signal as you dry-etch through a stack of thin-film layers, using an open-source electromagnetics module.
  • nk.py (Demis D. John)
    • Python functions for returning n (ref. idx.) & k (ext. coeff.) of various NanoFab thin-films at a specified wavelength (aka. dispersion models).